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BAB III 

RANCANGAN APLIKASI PENGENDALIAN MATERIAL 

KONSTRUKSI BERBASIS DATABASE 

 

Rancangan aplikasi manajemen material dikembangkan dengan maksud 

untuk memberikan informasi yang diperlukan dalam menunjang pengambilan 

keputusan, menyangkut manajemen material pada suatu proyek konstruksi. 

Rancangan ini diharapkan dapat pula mempermudah proses pemasukan data 

melalui form-form yang dibuat sesuai dengan kebutuhan dan menghasilkan 

laporan-laporan yang ringkas,cepat, dan terstruktur. Aplikasi yang dikembangkan 

belum dapat dipakai secara umum untuk setiap permasalahan konstruksi yang 

akan menerapkan aplikasi ini, dikarenakan bahwa masing-masing permasalahan 

konstruksi memiliki sistem yang berbeda-beda dilapangan dalam menerapkan 

manajemen untuk setiap proyek yang sedang ditangani. 

3.1  Metode Pengembangan Sistem Informasi Rancangan Aplikasi 

Terdapat berbagai metode dalam mengembangkan suatu sistem informasi 

manajemen diantaranya : 

1. Metode Top Down 

Pendekatan secara Top Down  bahasan untuk mengembangkan suatu 

model aliran informasi dalam organisasi dan merancang sistem Informasi yang 

sesuai dengan aliran informasi tersebut maanfaat dari model ini adalah adanya 

pendekatan yang sangat logis untuk pengembangan suatu rencana secara 

menyeluruh, adapun langkah-langkah dalam pengembangan metode ini adalah : 
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� Mengidentifikasi kegiatan organisasi dan fungsinya 

� Mengidentifikasi aliran informasi dan proses pengambilan keputusan 

� Mengelompokan proses pengambilan keputusan dan kebutuhan informasi 

dalam subsistem dan model. 

� Menentukan prioritas untuk pengembangan basis data 

2. Metode Bottom Up 

Pendekatan secara Bottom Up merupakan cara pengembangan suatu 

rencana menyeluruh sistem informasi berdasarkan pengoperasian model yang 

sesuai dengan permintaan. Manfaat dari metode ini adalah bahwa sistem informasi 

yang dirancang memberikan tahapan secara langsung terhadap kebutuhan nyata 

para pengambil keputusan, langkah-langkah yang dilakukan dalam metode ini 

adalah antara lain : 

� Mengumpulkan semua dokumen masukan dan laporan yang digunakan 

dan mengidentifikasi data tersebut. 

� Data dari dokumen masukan dan laporan yang terkumpul kemudian 

dikembangkan sistem basis datanya 

� Mengidentifikasi kebutuhan informasi dalam pengambilan keputusan 

� Mengembangkan sistem informasi manajemen yang dibutuhkan 

3. Metode Kombinasi 

Metode ini merupakan gabungan dari kedua metode diatas dalam 

pengembangan metode ini pendekatan top down dan pendekatan botton up 

dilakukan bersama - sama untuk mendapatkan suatu rancangan sistem informasi 

yang sesuai dengan kebutuhan perusahaan pendekatan top up digunakan untuk 
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mendapatkan bentuk sistem informasi dalam struktur yang menyeluruh. 

Sedangkan pendekatan botton up digunakan untuk memenuhi kebutuhan para 

pengambil keputusan. 

Dalam tugas akhir akan digunakan metode pendekatan Botton Up dimana 

pada tahap awal pengembangan suatu sistem informasi diidentifikasikan terlebih 

dahulu kebutuhan perusahaan akan dokumen masukan dan laporan. Untuk 

kepentingan sistem informasi manajemen material, selanjutnya didefinisikan 

mengenai aliran informasinya kemudian dikembangkan sistem basis datanya. 

Selain itu diidentifikasikan kebutuhan informasi dalam pengambilan keputusan 

dan mengembangkan sistem informasi yang dibutuhkan pada pekerjaan proyek 

konstruksi. 

3.2   Tahapan Pengembangan Rancangan Aplikasi 

Langkah-langkah yang dilakukan dalam perancangan aplikasi ini dimulai 

dengan analisis proses manajemen material yang dilakukan oleh Divisi Logistik                   

PT.Tribina Primalestari  kemudian dilanjutkan dengan merancang dokumen 

masukan dan laporan yang diperlukan pihak perusahaan konstruksi dalam 

manajemen material proyek konstruksi. 

 Berdasarkan analisis tahap manajemen material proyek konstruksi dapat 

diperoleh gambaran tentang lingkup manajemen material proyek konstruksi 

ditetapkan patokan yang meliputi objek utama dan fungsi utama sebagai 

pendukung dari tatanan manajemen material objek dan fungsi utama dapat 

diuraikan sebagai berikut : 
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1. Objek utama dalam manajemen material proyek konstruksi 

 Objek utama adalah representasi dari wujud data yang dapat menjadi 

sumber untuk menghasilkan informasi terkait dengan kepentingan manajemen 

material objek utama tersebut adalah : 

a. Pemasukan barang material konstruksi, informasi yang digunakan 

adalah : 

� Kode barang material  

� Jumlah material 

� Nama barang material 

� Harga satuan barang material 

� Satuan 

� Total biaya material 

� Pembayaran bahan material  

� Petugas Gudang 

� Nama supplier 

� No faktur pembelian 

b. Pengeluaran barang material konstruksi, informasi yang digunakan 

adalah : 

� Kode barang material 

� Jumlah material  

� Nama barang material 

� Stok barang yang ada  

� Satuan barang  
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� Sisa stok barang  

� Petugas gudang 

2. Fungsi utama dalam manajemen material proyek konstruksi 

 Fungsi utama yang perlu dipahami dalam pengoperasiaan manajemen 

material proyek konstruksi meliputi semua fungsi yang diperlukan sesuai dengan 

kepentingan keterkaitan setiap objek utama dengan manajemen material proyek 

kontruksi, jadi terdapat sejumlah fungsi spesifik yang diperlukan terkait dengan 

setiap objek. 

a. Untuk pemasukan barang material diperlukan fungsi sebagai berikut : 

� Fungsi pemantauan penerimaan barang material 

� Fungsi pemantauan ketersediaan material pada gudang 

b. Untuk pengeluaran barang material konstruksi diperlukan fungsi 

sebagai berikut: 

� Fungsi Pemantauan stok barang masuk dan keluar 

� Fungsi pemantuan ketersediaan material untuk penggunaan pada  

pekerjaan             

� Fungsi pengendalian barang material keluar 

 Tahap rancangan aplikasi sistem basis data yang dikembangkan untuk 

menghasilkan perancangan suatu dokumen masukan dan laporan. Sedangkan 

proses akhir adalah pengembangan sistem pemprosesan data yang memberikan 

kemudahan bagi pemakai program aplikasi. tahapan pengembangan rancangan 

aplikasi digambarkan sebagai berikut : 
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Gambar 3.1 Tahap Pembuatan Rancangan Aplikasi 
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3.3  Rancangan Aplikasi Macro Excel 

 Macro merupakan fitur excel yang digunakan dalam pembuatan database 

penerimaan dan pengeluaran material konstruksi, dengan menggunakan macro 

aplikasi peneriman dan pengeluaran material akan lebih interaktif sehingga 

transaksi dan data yang akan dihasilkan akan lebih efektif dan dijalankan secara 

otomatis. Macro dibuat dengan cara penulisan kode program untuk melaksanakan 

suatu perintah pada  Window Code Visual Basic Editor secara default excel akan 

menampilkan kotak dialog  Security Warning pada setiap workbook yang 

didalamnya terdapat macro. Untuk memperlancar pemuatan aplikasi penerimaan 

dan pengeluaran material konstruksi, maka kotak dialog Security Warning akan 

kita non-aktifkan dengan langkah-langkah sebagai berikut : 

1. Pilih Menu Tools > Macro > Security….maka akan muncul kota dialog 

security seperti terlihat pada gambar 3.2. 

 

 

 

 

 

 

 

Gambar 3.2  Kotak Dialog Security-tab Security Level. 
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2. Pilih tab Security L evel agar Macro yang terdapat dalam workbook selalu  

dijalankan tanpa melalui kotak dialog security warning  pilih Low 

3. Pilih tab Trusted Publishers beri tanda centang (�) pilih Trust all 

installed add-ins and templates dan Trust acces to Visual Basic Project 

kemudian tekan tombol OK  

 

 

 

 

 

 

Gambar 3.3  Kotak Dialog Security-tab Trusted Publishers 

3.3.1   Pembuatan Worksheet  

 Workbook excel yang dibuat menjadi aplikasi penerimaan dan 

pengeluaran barang material konstruksi mempunyai lima buah worksheet sebagai 

berikut : 

1. Worksheet Form  yang digunakan sebagai tempat untuk membuat Tabel 

Bantu Barang,Tabel Bantu Form Penerimaan dan Pengeluaran 

material,Tabel Bantu From Database,Tabel Bantuan Form Login Petugas 

dan Administrator. Fungsi utama dari worksheet ini adalah untuk 

melakukan transaksi penerimaan dan pengeluaran barang material 

konstruksi worksheet form dijadikan sebagai bidang untuk menampung 

objek kontrol  worksheet form selanjutnya disebut sebagai Form Sheet  
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Gambar 3.4  Worksheet Form (Form Sheet Penerimaan Barang Material) 

 

 

 

 

 

 

 

Gambar 3.5  Worksheet Form (Form Sheet Pengeluaran Barang Material) 

2. Worksheet Database yang digunakan sebagai tempat untuk menyimpan 

database penerimaan dan pengeluaran barang material seperti pada gambar  

 

 

 

 

 

Gambar 3.6 Worksheet Database Penerimaan Barang Material 
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Gambar 3.7 Worksheet Database Pengeluaran Barang Material 

3. Worksheet PivotTable digunakan sebagai tempat untuk menyimpan 

laporan dalam bentuk PivotTable. 

 

 

 

 

 

Gambar 3.8 Worksheet PivotTable 

4. Worksheet PivotChart digunakan sebagai tempat untuk menyimpan 

laporan dalam bentuk PivotChart 

 

 

 

 

 

 

 

Gambar 3.9 PivotChart untuk Penerimaan Barang 
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Gambar 3.10 PivotChart untuk Ketersediaan Barang 

5. Worksheet Nota digunakan sebagai tempat untuk membuat nota 

penerimaan barang dan Pengeluaran Barang 

 

 

 

 

 

 

Gambar 3.11 Nota Penerimaan Barang Material 

3.3.2  Pembuatan Form 

  Sebagai sebuah aplikasi Penerimaan dan Pengeluaran Barang material 

konstruksi mempunyai 3 buah form sebagai berikut : 

1. Form login petugas digunakan sebagai penampung User ID dan 

Password yang harus diisi pengguna dengan otoritas petugas gudang untuk 
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menggunakan aplikasi penerimaan dan pengeluaran bahan material 

konstruksi dengan hak akses terbatas. 

 

 

 

 

              Gambar 3.12 Form Login Petugas 

2. Form Login Administrator  digunakan sebagai penampung User ID dan 

Password yang harus diisi pengguna dengan otoritas administrator untuk 

menggunakan aplikasi penerimaan dan pengeluaran material konstruksi 

dengan hak akses penuh  

 

 

 

 

                        Gambar 3.13 Form Login Administrator 

3. Form Sheet digunakan untuk melakukan transaksi penerimaan dan 

pengeluaran barang material yang merupakan sebuah worksheet biasa 

yang dijadikan bidang untuk menampung objek kontrol 
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3.4  Membuat Database Penerimaan Dan Pengeluaran Material  

    Database dalam aplikasi penerimaan dan pengeluaran dibuat untuk 

menampung data transaksi penerimaan maupun pengeluaran barang material. 

Dengan membuat database kita dapat dengan mudah mengelola dan memperolah 

informasi kembali setiap transaksi penerimaan dan pengeluaran yang telah 

dilakukan database dapat dengan mudah menggunakan excel karena worksheet 

excel tersusun dalam bentuk kolom dan baris-baris. Contoh database penerimaan 

dan pengeluaran pada gambar 3.14 

 

 

 

 

 

 

 

Gambar 3.14 Contoh Database Penerimaan 

 

 

 

 

 

 

Gambar 3.15 Contoh Database Pengeluaran 
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Langkah-langkah pengerjaan pembuatan database penerimaan dan pengeluaran 

sebagai berikut : 

1. Jalankan program Microsof Excel kemudian buat workbook baru ubah 

nama workseet kedua menjadi database. Klik kanan tab nama worksheet 

yang akan diganti (Sheet2) kemudian pilih menu Rename ketikan 

Database pada tab yang sudah terseleksi tekan tombol Enter. 

 

 

 

Gambar 3.16 Mengubah Nama Worksheet 

2. Dengan cara yang sama ubah nama worksheet pertama (sheet 1) menjadi 

Form dan (sheet 3) menjadi PivotTable 

3. Untuk mengubah lebar kolom A tempatkan pointer pada sembarang disel 

di kolom A pilih menu Format > Column > Width...maka akan muncul 

kotak dialog width 

 

 

 

 

          Gambar 3.17 Kotak Dialog Column Width 

4. Pada kolom isian ketik 11 kemudian tekan tombol OK  untuk memberikan 

nama field pada kolom A yang berisi data tanggal transaksi penerimaan 

ketik Tanggal pada Sel A2 
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5. Dengan cara yang sama ubah lebar kolom serta tambahkan nama field 

pada kolom B sampai dengan H dengan ketentuan sebagai berikut : 

Kolom Lebar Kolom Sel Judul Kolom 

B 10 B2 No.Faktur 

C 18 C2 Petugas Gudang 

D 20 D2 Nama Barang 

E 12 E2 Harga 

F 10 F2 Jumlah 

G 10 G2 Satuan 

H 13 H2 Total 

           

                 Tabel 3.1 Mengatur Lebar Kolom Penerimaan 

6. Dengan cara yang sama untuk form pengeluaran ubah lebar kolom serta 

tambahkan nama field pada kolom B sampai sengan H dengan ketentuan 

sebagai berikut : 

Kolom Lebar Kolom Sel Judul Kolom 

B 10 B2 No.Form 

C 18 C2 Petugas Gudang 

D 20 D2 Nama Barang 

E 12 E2 Stok Barang 

F 10 F2 Jumlah 

G 10 G2 Satuan 

H 13 H2 Sisa Stok 

           

        Tabel 3.2 Mengatur Lebar Kolom Pengeluaran 

 



Rancangan Aplikasi Pengendalian Material Berbasis Database 

 

Pengendalian Material Konstruksi Berbasis Database  III - 16 

7. Untuk menambah border pada database blok range A2:H65536                                

(baris terbawah) pilih menu Format > Cells.... atau tekan Ctrl+1  muncul 

kotak dialog format cell dan pilih tab Border tekan tombol Outline dan 

Inside selanjutnya  tekan tombol OK  

 

 

 

 

 

 

 

Gambar 3.18 Menambahkan Border Pada Database 

8. Untuk melakukan format data dalam database langkah-langkah pengerjaan 

sebagai berikut : 

• Blok range A3:A65536 kemudian pilih menu Format > Cells... atau tekan 

Ctrl+1  muncul kotak dialog Format Cells pilih tab Number. pada daftar 

pilihan Category pilih Costum kemudian ketik dd/mm/yyy pada kotak 

isian Type tekan tombol OK  

• Blok range B3:D65536 dengan cara yang sama namun pada pilihan 

Category pilih General kemudian OK  

• Untuk range E3:E655536 pilih Category Currency pilih atau ketik 0 pada 

kotak isian desimal places kemudian pilih Rp  Pada kotak pilihan simbol 

lalu tekan OK  
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9. Tempatkan pointer pada sel A3 kemudian pilih menu Window > Freeze 

Panes langkah ini dilakukan agar judul kolom tidak tergulung pada saat 

pengisian data  terutama jika data dimasukan sudah cukup banyak. 

10. Tempatkan pointer pada sel A3 kemudian ketik formula = Now() untuk 

melengkapi baris berikutnya pada kolom A  tempatkan pointer pada sel A3 

kemudian pilih menu Edit > Copy atau tekan kombinasi Ctrl + C  

11. Blok Sel A3:A19 kemudian pilih menu Edit > Paste Special muncul 

kotak dialog paste spesial pada daftar pilihan Paste  pilih Values kemudian 

tekan tombol OK  

3.4.1  Menyaring Data (Filter) 

 Untuk menyaring data dalam database dengan kriteria tertentu setelah 

dilakukan penyaringan data yang ditampilkan hanya record yang memenuhi 

kriteria yang telah ditentukan langkah pengerjaan adalah : 

1. Blok judul kolom dalam database yaitu A3:H3 pilih menu Data > Filter > 

AutoFilter  muncul drop-down pada setiap judul kolom seperti pada 

gambar 3.19 

 

 

 

 

 

 

                Gambar 3.19 Drop-down Pada Setiap Judul Kolom 
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2. Untuk melakukan penyaringan klik drop-down pada judul kolom yang 

akan disaring datanya misalnya judul kolom petugas gudang muncul daftar 

penyaringan seperti pada gambar 3.20 

 

 

 

 

Gambar 3.20  Daftar Pilihan Penyaringan 

3. Untuk daftar melakukan pengaturan penyaringan dari daftar pilihan yang 

disediakan yaitu : 

• Sort Ascending pilihan untuk mengurutkan data secara menaik 

berdasarkan kolom yang dipilih 

• Sort Descending pilihan untuk mengurutkan data secara menurun 

berdasarkan kolom yang dipilih 

• All  Pilihan untuk menampilkan seluruh data dalam database 

berdasarkan kolom yang dipilih 

• (Top 10...) pilihan untuk menampilkan record dengan data yang 

mempunyai nilai terendah atau tertinggi pada kolom yang dipilih. 

Pilihan ini tidak berlaku pada data teks 

• (Custom...) pilihan untuk menampilkan record dengan kriteria yang 

ditentukan. 
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• Data unik pilihan untuk menampilkan record berdasarkan data unik 

yang ada dalam kolom yang dipilih dalam contoh kali ini ada 2 data 

unik yaitu Denni dan Supri 

4. Setelah drop-down pada kolom petugas gudang di-klik pilih Supri sebagai 

kriteria penyaringan maka tampilan database yang telah disaring akan 

terlihat seperti pada gambar 3.21 

 

 

 

 

 

 

Gambar 3.21 Database Hasil Penyaringan 

5. Untuk menampilkan kembali seluruh record data dalam database pilih 

menu  Data > Filter > Show All 

3.4.2  Memberi Nama Range 

 Untuk mempermudah dan membuat kode macro kita harus memberikan 

nama pada range  adapun langkah pengerjaannya adalah : 

1. Untuk memberikan nama range database penerimaan dan pengeluaran 

pilih terlebih dahulu menu Insert > Name > Define...maka akan muncul 

kotak dialog Define Name seperti terlihat pada gambar 3.22 
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Gambar 3.22 Kotak Dialog Define Name 

2. Ketik Database pada kotak isian Names in workbook : pada kotak isian 

refers to : ketik =Database!$A$2:$H$65536. 

3. Blok range A2:H65536 (hasil blok range ditandai dengan garis terputus-

putus tekan tombol          muncul kembali kotak dialog Define Name tekan 

Tombol Add.  

 

 

  

 

Gambar 3.23 Nama Range Database 

4. Untuk memberikan nama pada range data dalam database penerimaan dan 

pengeluaran ketik DataDatabase pada kotak isian Names in workbook : 

pada kotak isian refers to : ketik = Database!$A$3:$H$65536 dan tekan 

tombol Add selanjutnya tekan tombol OK  
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3.4.3  Mengatur Percetakan Database 

 Pengaturan percetakan database dilakukan agar hasil cetakan mampu 

memberikan informasi yang mudah dipahami untuk setiap field dan record data 

penerimaan dan pengeluaran bahan material konstruksi. Adapun langkah-langkah 

yang pengerjaan adalah : 

1. Pilih menu File > Page Setup... maka akan mucul dialog page setup 

2. Pilih tab Page untuk menentukan ukuran dan penataan halaman dimana 

langkah-langkahnya sebagai berikut : 

• Untuk memperoleh hasil percetakan database dalam posisi tegak pilih 

Potrait pada opsi Orientation 

• Pada opsi Scaling pilih opsi Adjust to: kemudian ketik 80 % normal 

size yang berarti besarnya hasil percetakan adalah 80 % dari ukuran 

normal. 

• Untuk menentukan pilihan ukuran kertas pilih A4 pada kotak pilihan 

Paper Size 

• Pilih High pada kotak pilihan Print quality untuk memperoleh hasil 

percetakan dengan kualitas tinggi. 

• Pada kotak isian First page number biarkan dengan isian default Auto 

yang berarti percetakan diawali dari halaman 1 
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Gambar 3.24  Kotak Dialog Page Setup-tab page 

3. Pilih tab Margin  untuk menentukan batasan percetakan database 

penerimaan dan pengeluaran dengan tepi halaman kertas.langkah-

langkahnya sebagai berikut : 

• Untuk menentukan batasan atas bidang percetakan ketik 2,7 pada 

kotak isian Top 

• Ketik 1,9 pada kotak isian Left untuk menentukan batas kiri bidang 

percetakan 

• Ketik 1,4 pada kotak isian Right untuk menentukan batasan kanan 

bidang percetakan 

• Untuk menentukan batasan bawah bidang percetakan,ketik 2 pada 

kotak isian Botton 

• Untuk menentukan jarak Header 1 dan Footer 0,5 
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Gambar 3.25 Kotak Dialog Page Setup-tab Margins 

3.4.4  Kode Macro Penerimaan dan pengeluaran Material Konstruksi 

 Agar window ditampilkan dengan ukuran 95% pada saat worksheet 

database aktif maka langkah-langkah yang harus dilakukan adalah sebagai berikut  

1. Pilih menu Tools > Macro > Visual Basic Editor (atau tekan Alt+F11) 

untuk membuka Visual Basic Editor 

2. Pilih menu View > Project Explorer  (atau tekan Ctrl+R ) untuk 

membuka window Project Explorer 

3. Pilih object Sheet2(database) pada Microsoft Excel Objects dalam proyek 

VBAProject  

4. Pilih menu View > Code > atau tekan F7 kemudian ketik kode sebagai 

berikut : 

'Kode saat worksheet Database aktif 

Private Sub Worksheet_Activate() 

ActiveWindow.Zoom = 95 

End Sub 
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Gambar 3.26  Memilih Object Sheet 2 

 

 

 

 

 

Gambar 3.27 Kode Saat worksheet database aktif 

3.5  Membuat PivotTable dan PivotChart 

 PivotTabel merupakan tabel yang merangkum informasi tertentu dalam 

sebuah database berbeda dengan tabel umumnya,PivotTable merupakan tabel 

yang bersifat interaktif. Tampilan pivottable bisa diatur sedemikian rupa sehingga 

data lebih mudah dianalisis kita dapat membuat pivotTable sesuai dengan 

keinginan kita dan analisa yang kita harapkan. 

 PivotTable ditempatkan diluar pada range database sehingga tidak 

mengubah isi dan tampilan database yang dianalisis. Kelebihan PivotTable adalah 

hasil analisis dapat dibuat dalam bentuk grafik dengan mudah menggunakan 
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PivotChart sama halnya dengan PivotTable tampilan PivotChart juga dibuat 

sedemikian rupa sehingga mudah dianalisis. 

3.5.1  Membuat PivotTable 

 Dalam pembuatan pivotable kita bisa menggunakan acuan hasil database 

penerimaan sehingga bisa diolah dengan baik langkah pembuatan PivotTable 

adalah : 

1. Pilih menu Data > PivotTable and PivotChart Report….maka akan 

muncul kotak dialog PivotTable and PivotChart Wizard – Step 1 of 3 

seperti pada gambar berikut : 

 

 

 

 

 

 

 

Gambar 3.28 Kotak Dialog PivotTable & PivotChart 

2. Pilih opsi Microsoft Office Excel list or database karena sumber data 

berada pada pivottable yag kita digunakan berasal dari tabel atau database 

excel yaitu database penerimaan barang material yang terdapat dalam 

worksheet database tekan tombol Next > maka akan muncul kotak dialog 

pivottable and pivotchart wizard step 2 of bisa dilihat pada gambar 3.29 
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3. ketik =database pada kotak isisn renge,database merupakan nama range 

database pada worksheet database tekan tombol Next > maka muncul 

kotak dialog seperti terlihat pada gambar 3.30 

 

 

 

 

Gambar 3.29 Kotak Dialog PivotTable & PivotChart Step 2 

 

 

 

 

 

Gambar 3.30 Kotak Dialog PivotTable & PivotChart Step 3 

4. Tekan tombol Layout….untuk melakukan pengaturan tampilan posisi 

field yang diinginkan. Muncul kotak dialog pivottable and pivotchart 

wizard-layout seperti gambar 3.31 

 

 

 

 

  

Gambar 3.31  Kotak dialog Pivottable and Pivotchart wizard-layout 
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5. Atur posisi tampilan field dalam database penerimaan dengan langkah-

langkah berikut : 

• Tarik field Nama barang ke bagian Row serta jumlah dan total 

kebagian Data 

• Klik ganda field Jumlah pada bagian data. maka akan muncul 

kotak dialog gambar 3.32 

 

 

 

 

 

Gambar 3.32 Kotak dialog PivotTable Field 

• Pilih Sum pada daftar pilihan Summarize by : kemudian tekan 

tombol Ok lakukan dengan cara yang sama terhadap field Total 

pada bagian Data  

• Atur posisi sehingga tampilan database sesuai dengan yang 

didinginkan 

 

 

 

 

 

 Gambar 3.33  Tampilan PivotTable Setelah dilakukan pengaturan 
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3.5.2  Membuat PivotChart 

 Tampilan PivotTable akan lebih informatif jika disertai grafik sebagai 

penunjang kita dapat membuat grafik dari pivottable yang telah dibuat dengan 

mudah menggunakan fitur PivotChart. langkah atau pembuatan PivotChart adalah 

Klik kanan sembarang sel diarea PivotTable kemudian pilih menu PivotChart 

 

 

 

 

 

 

Gambar 3.34  Membuat PivotChart Melalui Menu Klik K anan 

langkah tersebut juga dapat dilakukan dengan cara menkan ikon       pada toolbar 

pivotTable PivotChart yang akan dibuat  tampak seperti gambar berikut : 

 

 

 

 

 

 

 

Gambar 3.35  PivotChart PT.Tribina Primalestari 
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untuk mengubah model garfik klik kanan pada area grafik kemudian pilih menu 

Chart Type...muncul kotak dialog Type seperti gambar 3.36 pilih menu Column 

pada daftar pilihan Chart type pada daftar pilihan Chart sub-type pilih Clustered 

column tekan tombol Ok. 

 

 

 

 

 

 

Gambar 3.36 Kotak Dialog Chart Type 

3.6  Membuat Nota Penerimaan dan Permintaan 

  Nota penerimaan dan permintaan barang material konstruksi merupakan 

laporan yang dibuat untuk mencatat total keseluruhan transaksi dalam setiap 

penerimaan dan pengeluaran barang material. Nota penerimaan diberikan kepada 

Supplier sebagai bukti bahwa barang kiriman sudah diterima oleh Kontraktor, 

sebaliknya untuk pengeluaran barang digunakan untuk bukti pengeluaran atau 

pengunaan barang material konstruksi. Bentuk nota penerimaan dibuat seperti 

pada gambar 3.37 
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          Gambar 3.37  Bentuk Nota Penerimaan Barang Material 

3.6.1  Membuat Worksheet Nota 

 Nota penerimaan yang dibuat akan ditempatkan pada worksheet tersendiri 

sehingga akan mempermudah dalam memasukan ataupun menghapus keterangan 

dan isi nota. Buka worksheet baru kemudian beri nama nota setelah itu blok 

seluruh sel dengan cara klik pada kotak disebelah pojok kiri atas perpotongan 

baris dan kolom atau tekan Ctrl+A  

 

 

 

Gambar 3.38  Klik Perpotongan Baris Dan Kolom 
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pilih menu Format > Cells... muncul kotak dialog format cells kemudian pilih 

Tab Protection beri tanda centang (�) pada pilihan Locked tekan tombol OK 

untuk mengubah lebar kolom pilih menu Format > Column > Width... sehingga 

muncul kotak dialog Width 

 

 

 

 

Gambar 3.39 kotak dialog Column Widht dan Row Height 

3.6.2  Keterangan Nota 

 Untuk menambahkan keterangan No.Faktur Tanggal dan Nama Supplier 

dibagian atas nota langkah pengerjaannya adalah : Tempatkan pointer pada sel D5 

kemudian ketik No.Faktur : Tempatkan pointer pada sel D6 kemudian ketik 

Tanggal : Tempatkan pointer pada sel D7 kemudian ketik Nama : Blok range 

D5:D7 pilih menu Format > Cells....maka kan muncul kotak dialog format Cells 

kemudian pilih Tab Alignment 

 

 

 

 

 

 

Gambar 3.40 Mengatur Perataan Teks Pada Keterngan Nota 
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Pada kotak pilihan Horizontal  pilih Right (indent) pilih Center pada kotak pilih 

vertical tekan tombol OK  lengkapi pembuatan nota sehingga seperti pada gambar 

dibawah ini 

 

 

 

 

 

 

 

Gambar 3.41 Hasil Pembuatan Nota 

3.6.3  Memberi Nama dan Membuat Proteksi Range 

 Untuk mempermudah dalam pembuatan kode macro maka perlu dilakukan 

sebagai berikut :  

1. untuk memberikan range pada keterangan nota,pilih menu Insert > Name 

> Define...maka akan muncul kotak dialag Define Name seperti terlihat 

pada gambar 3.42 

 

 

 

 

         Gambar 3.42 Kotak Dialog Define Name 
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2. Untuk memberi nama range isi nota ketik Isinota pada kotak isian Names 

in workbook dengan menekan dan menahan tombol Ctrl arahkan pointer 

pada Sel E 5,E 6,E 7,F 42,C 54, dan F 54 

3. Pilih menu Format > Cells muncul kotak dialog Protection 

4. Hilangkan centang (�) pada pilihan Locked.tekan tombol OK 

3.6.4  Kode Macro Nota 

 Agar window ditampilkan dengan ukuran 120 % pada saat worksheet nota 

aktif langkah pengerjaannya adalah : 

1. Pilih menu Tools > Macro > Visual Basic Editor sehingga kotak dialog 

untuk membuka Visual Basic Editot terbuka. 

2. Pilih menu View > Project Explorer  untuk membuka window project 

explorer 

3. Pilih object nota Sheet4 (Nota) pada Microsoft Excel Object dalam project 

VBAproject 

4. Pilih menu View > Code > atau tekan F7 kemudian ketik kode sebagai 

berikut : 

‘kode saat worksheet Database aktif 

Private Sub worksheet_Activate ( ) 

Activewindow.Zoom = 120 

End Sub 
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     Gambar 3.43  Kode Saat Workshet Database Aktif 

3.7  Rancangan Pembuat Form Sheet 

 Jika database penerimaan dan pengeluaran barang material sudah 

mempunyai banyak record data maka seringkali kita akan mengalami kesulitan 

ketika harus melakukan input,edit ataupun menghapus tiap record data. Masalah 

tersebut sebenarnya bisa diatasi dengan membuat form yang dibuat untuk 

pekerjaan penerimaan dan pengeluaran dimana kedunya bisa menampung kotrol 

yang dibutuhkan. Untuk pembuatan tampilan penerimaan dibuat secara form 

penerimaan dan untuk pengeluaran berbeda sedikit dari form penerimaan.langkah 

pertama untuk mengerjakan atau membuat form sheet membuat tabel 

bantu,mendesain Form,dan pembuatan kode Macro. 

3.7.1 Membuat Tabel Bantu 

 Pembuatan tabel bantu ditujukan untuk mempermudah pengisian beberapa 

field dalam transaksi penerimaan dan pengeluaran barang material konstruksi 

ataupun sebagai kode pengisian User ID dan Password dalam login petugas 

gudang atupun login Administrator. Tabel bantu yang dibutuhkan adalah tabel 

bantu barang,tabel bantu form penerimaan dan pengeluaran,tabel bantu form 

database,tabel bantu form login petugas dan adminstrator. Sebelum kita membuat 
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tabel bantu maka terlebih dahulu kita membuat tampilan untuk form sheet.cara 

pengerjaannya adalah : 

1. Pilih worksheet Form kemudian blok seluruh sel dengan cara klik pada 

kotak di sebelah pojok kiri atas perpotongan baris dan kolom (atau tekan 

Ctrl+A ) 

 

 

Gambar 3.44 Klik Perpotongan Baris dan Kolom 

2. Pilih menu Format > Cells...atau tekan Ctrl+1  maka akan muncul dialog 

Format Cells kemudian pilih tab Patterns 

3. Pada daftar pilihan Color pilih warna yang akan dijadikan background 

form sheet kemudian pilih tab Protection 

4. Beri tanda centang (�) pada pilihan Locked lalu tekan tombol OK  

3.7.2  Tabel Bantuan Barang 

 Tabel bantuan barang dibuat untuk mempermudah dalam pengisian 

beberapa filed agar tidak perlu mengisi semua field yang dibutuhkan dalam 

transaksi penerimaan dan pengeluaran. Setelah tabel bantu dibuat kita hanya perlu 

mengisi kode barang dan jumlah barang langkah pengerjaanya adalah : 

1. Tempatkan pointer pada Sel N1 kemudian ketik tabel bantuan barang 

2. Untuk mengubah lebar kolom disesuaikan dengan kapasitas teks yang ada 

3. Untuk menambahkan border pilih menu Format > Cells...maka akan 

muncul kotak dialog pilih tab Border tekan tombol Outline dan Inside 

selanjutnya tekan OK  
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4. Untuk menambah judul pada tabel barang maka tempatkan pointer di sel 

yang akan diberi judul langkah-langkah sebagai berikut : 

• Tempatkan Pointer pada sel N2 dan ketik Kode 

• Tempatkan Pointer pada sel O2 dan ketik Nama Barang 

• Tempatkan Pointer pada sel P2 dan ketik Harga 

• Tempatkan Pointer pada sel Q2 dan ketik Satuan 

Untuk Form bantuan pengeluaran yaitu : 

• Tempatkan Pointer pada sel N2 dan ketik Kode 

• Tempatkan Pointer pada sel O2 dan ketik Nama Barang 

• Tempatkan Pointer pada sel P2 dan ketik Stok Barang 

• Tempatkan Pointer pada sel Q2 dan ketik Satuan 

5. Untuk melakukan format data dalam tabel bantuan barang langkah-

langkahnya : 

• Pilih Format > Cells... muncul kotak dialog format Cells pilih tab 

Number pada daftar pilih Category pilih General tekan OK  

• Untuk range lainya sama hanya yang membedakan untuk memilih daftar 

pilihan Categori ada pilihan Currency unuk tabel dalam bentuk Rp. 

• Lengkapi tabel bantuan barang sehingga seperti pada tabel  3.35 

• Untuk memberi nama pada range kode barang,pilih menu Insert > Name 

> Define...muncul kotak dialog Define Name pada kotak isian Names in          

workbooks: ketik kode barang kemudian ketik =OFFSET 

(Form!N$3;0;0;COUNTA(Form!$N:$N)-2;1)  pada kotak isian Refere to 

: tekan Add lalu tekan OK  
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3.7.3  Tabel Bantuan Form Penerimaan dan Pengeluaran 

 Tabel bantuan Form penerimaan dan pengeluaran dibuat untuk 

menampilkan data setelah kita mengisi kode barang dan jumlah barang dalam 

Form Penerimaan dan pengeluaran langkah pengerjaannya 

1. Tempatkan pointer pada sel S1 kemudian ketik Tabel Bantu Form 

Penerimaan  

2. Sesuaikan lebar kolom S dengan teks yang ditentukan 

3. Untuk menambahkan Border pilih menu Format > Cells...maka akan 

muncul kotak dialaog pilih tab Border tekan tombol Outline dan Inside 

selanjutnya tekan OK  

4. Untuk menambah judul pada tabel bantuan tempatkan Pointer sel S2 

kemudian ketik Keterangan dan sel T2 kemudian ketik Nilai.  

5. Untuk melakukan format data dalam tabel bantuan barang langkah-

langkahnya 

• Pilih Format > Cells... muncul kotak dialog format Cells pilih tab Number 

pada daftar pilih Category pilih General tekan OK  

• Untuk range lainya sama hanya yang membedakan untuk memilih daftar 

pilihan Categori ada pilihan Currency unuk tabel dalam bentuk Rp. 

• Lengkapi kolom keterangan pada tabel bantuan form penerimaan dan 

pengeluaran hingga terlihat seperti pada gambar 3.45 
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Gambar 3.45 Melengkapi Keterangan Tabel Bantuan Penerimaan 

6. Untuk melengkapi kolom nilai pada tabel bantuan form penerimaan langka 

pengerjaannya adalah  

• Tempatkan pointer pada sel T3 dan ketik sembarang Kode Barang 

misalnya ketik kode Se (Seng Plat) 

• Ketikan = If(T3=””;””;VLOOKUP(T3;tabel barang;2;0))  pada sel 

T4 

• Ketikan =IF(T3=””;””;VLOOKUP(T3;tabelbarang;3;0))  pada sel 

T5 

• Ketikan sembarang jumlah barang pada sel T6 misalnya ketik 3 

• Ketik =IF(OR(T3=””;T6=””);””;(T5*T6))  di sel T8 

Apabila semua dilakukan dengan benar tampilan tabel bantu form akan 

terlihat pada gambar 3.46 

7. Dengan menekan dan menahan tombol Ctrl  tempatkan pointer pada sel T3 

dan T6 dalam keadaan terseleksi pilih menu Format > Cells...atau tekan 
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Ctrl+1  maka muncul kotak dialog Format Cells kemudian pilih tab 

Protection 

8. Hilangkan tanda centang pada pilihan Locked lalu tekan tombol OK  

 

 

 

 

 

 

Gambar 3.46 Tabel Bantu Form Penerimaan 

3.7.4  Tabel Bantu Form Login Petugas  

 Tabel bantuan form login petugas dibuat sebagai tabel bantu yang berisi 

kode user ID dan Password yang harus dimasukan petugas dalam form login 

petugas langkah-langkah untuk membuat tabel bantu login adalah : 

1. Tempatkan pointer  pada sel Y1 kemudian ketik tabel bantu form login 

petugas 

2. Sesuaikan lebar kolom Y dengan panjang teks yang ditentukan 

3. Untuk menambah judul pada tabel bantuan form login petugas adalah 

tempatkan pointer pada sel Y2 dan ketik Petugas Gudang kemudian 

tempatkan pointer pada sel Z2 ketik Password 

4. Untuk melakukan format data dalam tabel bantu form login petugas,blok 

range Y3:Z65536 kemudian pilih menu Format > Cells... atau tekan 
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Ctrl+1  muncul kotak dialg format cells. Pilih tab Number pada daftar 

Category pilih General tekan tombol OK 

5. Lengkapi kolom petugas dan password pada tabel bantu form login 

petugas. 

6. Untuk memberi nama pada range nama petugas pilih menu Insert > Name 

> Define...muncul kotak dialog Define Name.Pada kotak isian Names in 

workbook ketik Nama petugas pada kotak isian Refere to : ketik = 

OFFSET (form!$Y$3;0;0;COUNTA(Form!$Y:$Y)-2;1)  dan tekan 

tombol Add 

7. Tempatkan pointer pada sel AA2 dan ketik Login Petugas 

8. Ketik User ID pada sel AA3 dan Password pada sel AA4 

9. Ketik sembarang nama petugas pada sel AB3 misalnya Ketik Denni 

10. Ketik =IF(AB3=””;””;VLOOKUP(AB3;Tabelpenerimaan;2;0))  pada 

sel AB4 

11. Tempatkan pointer pada sel AB3 pilih menu Format > Cells…atau tekan 

Ctrl+1  sehingga muncul kotak dialog format Cells kemudian pilih tab 

Protection 

12. Hilangkan tanda centang (�) pada pilihan Locked tekan OK  

3.7.5  Tabel Bantuan Form Login Administrator 

 Tabel bantuan form login administartor dibuat sebagai tabel bantu yang 

berisi kode user id dan password yang harus dimasukan administrator dalam form 

Login administrator langkah awal pengerjaannya adalah : 
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1. Tempatkan pointer pada sel AD1 dan ketik tabel bantuan form login 

administrator 

2. Sesuaikan lebar kolom Y dengan panjang teks yang ditentukan 

3. Tempatkan pointer pada sel AD2 dan ketik Login Administrator 

4. Ketik User ID pada sel AD3 dan Password pada sel AD4 

5. Ketik user id yang akan digunakan untuk login sebagai adminstrator pada 

sel AE3 misalnya Ahmad 

6. Ketik Password yang akan digunakan untuk login sebagai administrator 

pada Sel AE4 misalnya Ketik Damha 

7. Apabila semua dilakukan secara benar maka akan tampil seperti pada 

gambar 3.47 

 

 

 

 

 

 

 

Gambar 3.47 Tabel Bantuan Form Login Petugas Dan Administrator 
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3.8  Rancangan Desain Form 

3.8.1  Menentukan Lebar Kolom 

1. Untuk mengubah lebar kolom A tempatkan pointer pada sembarang sel 

dikolom A pilih menu Format > Column > Width...muncul kotak dialog 

column width pada kotak isian ketik 2 kemudian tekan Ok 

2. Dengan cara yang sama ubah lebar kolom B menjadi 13 kolom C menjadi 

12 kolom D menjadi 0,5 kolom E menjadi 12 Kolom F menjadi 13 kolom 

G menjadi 3 kolom H menjadi 10 kolom I  menjadi 14 dan kolom J 

menjadi 12 

3.8.2  Judul dan Deskripsi Form 

1. Blok range B1:I2 pilih menu Format > Cells …atau tekan Ctrl+1 muncul 

kotak dialog format cells kemudian pilih tab Alignment pada kotak 

pilihan Horizontal  dan Vertical  pilih center beri tanda centang pada 

pilihan Mergen Cells kemudian pilih tab Font 

2. Pada daftar pilihan Font pilih Arial  kemudian Bold Italic  pada daftar 

pilhan Font style  ketik 20 pada kotak isian Size. 

3. Pilih warna yang akan dijadikan background deskripsi form tekan Ok 

ketik PT.TRIBINA PRIMALESTARI sebagai deskripsi form 

3.8.3   Menambah keterangan Kode dan Jumlah Barang 

1.  Blok range B5:C6 pilih menu Format > Cells...atau tekan Ctrl+1  muncul 

kotak dialog  format cells kemudian pilih tab Border pada daftar pilihan 

Line-Style pilih garis tebal tekan tombol Outline dan Inside selanjutnya 

tekan tombol OK  
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2.   Tekan pointer pada sel C7  pilih menu Format > Cells...atau tekan Ctrl+1  

muncul kotak dialog  format cells kemudian pilih tab Border pada daftar 

pilihan Line-Style pilih garis tebal takan tombol Outline dan Inside 

selanjutnya tekan tombol OK  

3. Untuk menambah keterangan kode barang dan jumlah langkah 

pengerjaanya adalah : 

• Tempatkan pointer pada sel B5 ketik Kode barang 

• Tempatan pointer pada sel B6 dan ketik Jumlah 

4. Blok range B5:B6 pilih menu Format > Cells...atau tekan Ctrl+1  muncul 

kotak dialog  format cells kemudian pilih tab font pilih Arial  kemudian 

Bold ketik 10 pada isian Size tekan OK  

5.  Blok range C5:C pilih menu Format > Cells...atau tekan Ctrl+1  muncul 

kotak dialog  format cells kemudian pilih tab Patterns pilih warna white 

dan pilih tab Protection  

6. Hilangkan tanda centang (�) pada pilihan Locked kemudian tekan tombol 

OK .Tempatkan pointer pada sel C5 kemudian pilih menu Data > 

Validation...muncul kotak dialog data Validation  

 

 

 

 

 

Gambar 3.48 Kotak Dialog Data Validation-tab Settings 
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7. Pilih tab setting pada kotak pilihan Allow pilih list pada kotak isian 

Source ketik = kodebarang yaitu nama range yang berisi kode barang pilih 

tab Error Alert  lihat gambar  

8. Berti tanda centang (�) pada pilihan Show eror alert after invalid data 

is entered.pada kotak pilihan Style pilih Stop pada kotak isian Title  ketik 

Error kode barang ketik kode barang yang anda masukan tidak valid 

pada kotak isian Error message tekan tombol OK  

9. Tekan pointer pada sel C6 kemudian pilih menu Data > 

Validation...muncul kotak dialog Data Validation. 

10. Pilih Setting pada kotak pilihan Allow kemudiaan pilih Custom.pada kotak 

isian Formula ketik =ISNUMBER(C6) hal ini berarti data yang 

dimasukan dalam sel C6 harus berupa angka pilih tab Error Alert  

11. Beri tanda centang (�) pada pilihan Show eror alert after invalid data is 

entered pada kotak pilihan Style pilih Stop.pada kotak isian Title ketik 

jumlah barang ketik jumlah barang yang anda masukan tidak valid 

pada kotak isian Error message tekan tombol OK  

12. Tekan pointer pada sel C7 kemudian pilih menu Data > 

Validation...muncul kotak dialog Data Validation. 

13. Pilih Setting pada kotak pilihan Allow kemudian pilih Custom pada kotak 

isian Formula ketik =ISNUMBER(C7) hal ini berarti data yang 

dimasukan dalam sel C7 harus berupa angka pilih tab Error Alert  

14. Beri tanda centang (�) pada pilihan Show eror alert after invalid data is 

entered pada kotak pilihan Style pilih Stop pada kotak isian Title ketik 
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Erro Nomor Nota ketik No Nota yang anda masukan tidak valid pada 

kotak isian Error message tekan tombol OK  

3.8.4  Menambah keterangan Item Barang  

1. Blok range E5:F8 pilih menu Format > Cells …atau tekan Ctrl+1  

muncul kotak dialog format Cells kemudian pilih tab Border. Pada daftar 

pilihan Line-Style pilih garis tebal tekan tombol Outline dan Inside 

selanjutnya tekan tombol OK  

2. Untuk menambah keterangan setiap item barang maka langkah 

pengerjaannya adalah : 

• Tempatkan pointer pada sel E5 dan ketik Nama Barang 

• Tempatkan pointer pada sel E6 dan ketik Harga barang 

• Tempatkan pointer pada sel E7 lalu ketik Satuan 

• Tempatkan Pointer pada Sel E8 selanjutnya ketik Total 

3. Untuk menambahkan isi dari setiap item barang lakukan langkah-langkah 

berikut : 

• Ketik =IF(C5=””;””;VLOOKUP(C5;Tabelbarang;2;0))  

• Ketik =IF(C5=””;””;VLOOKUP(C5;Tabelbarang;3;0))  

• Ketik =IF(OR(C5=””;C6=””);””;(C6-F7))  

4. Untuk form pengeluaran barang hanya dibedakan dari : 

•  Tempatkan pointer pada sel E5 dan ketik Nama Barang 

• Tempatkan pointer pada sel E6 dan ketik Stok Barang 

• Tempatkan pointer pada sel E7 lalu ketik Satuan 

• Tempatkan Pointer pada Sel E8 selanjutnya ketik Sisa Stok 



Rancangan Aplikasi Pengendalian Material Berbasis Database 

 

Pengendalian Material Konstruksi Berbasis Database  III - 46 

3.8.5  Menambahkan keterangan Nota Faktur dan Petugas  

1. Blok range H5:I6  pilih menu Format > Cells …atau tekan Ctrl+1  muncul 

kotak dialog format cells kemudian pilih tab Border. pada daftar pilihan 

Line-Style pilih garis tebal tekan tombol Outline dan Inside selanjutnya 

tekan tombol OK  

2. Untuk menambah keterangan setiap item barang maka langkah 

pengerjaannya adalah : 

• Tempatkan pointer pada sel H5 dan Ketik No.Faktur / No.Form 

• Tempatkan pointer pada sel H6 selanjutnya Petugas Gudang 

3. Untuk menambahkan isi nota faktur atau form dan petugas langkah 

pengerjaanya adalah : 

• Ketik No faktur / form yang terakhir digunakan 

• Ketik nama petugas yang terakhir melakukan transaksi penerimaan dan 

pengeluaran barang 

4. Blok range I5 : I6 kemudian pilih menu Format > Cells...atau tekan 

Ctrl+1  muncul kotak dialog format cells pilih tab Protection 

5. Hilangkan tanda centang (�) pada pilihan Locked tekan tombol OK  

3.8.6  Menambah Keterangan Nota 

1. Untuk menambah keterangan pada nota langkah-langkah yang dilakukan 

adalah : 

• Tempatkan pointer pada sel H8 selanjutnya ketik Nama Supplier / 

Nama pekerja 

• Tempatkan pointer pada sel H10 lalu ketik Pembayaran  
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• Tempatkan pointer pada sel H12 ketik Sisa pembayaran 

2. Pilih tab Protection hilangkan tanda centang (�) pada pilihan Locked 

kemudian tekan tombol OK  

3. Tekan pointer pada sel H11 kemudian pilih menu Data > 

Validation...muncul kotak dialog Data Validation. 

4. Pilih Setting pada kotak pilihan Allow kemudian pilih Custom pada kotak 

Isian Formula ketik =ISNUMBER(H11) pilih tab Error Alert  

5. Berti tanda centang (�) pada pilihan Show eror alert after invalid data 

is entered pada kotak pilihan Style pilih Stop. Pada kotak isian Title ketik 

pembayaran ketik data yang anda masukan tidak valid pada kotak 

isian Error message tekan tombol OK  

6. Tempatkan pointer pada sel H13 kemudian ketik =H11 - H18 

 

 

 

 

 

 

Gambar 3.49 Tampilan Awal Form Sheet 

3.8.7  Menambahkan Kontrol pada Form Sheet 

 Agar form sheet lebih interaktif kita dapat menambahkan objek kontrol 

seperti CommandButton,listbox dan objek kontrol lainya dalam worksheet 
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1. Sebelum menambahkan objek kontrol ke dalam worksheet anda harus 

mengaktifkan toolbar control toolbox terlebih dahulu pilih menu View > 

Toolbar > Control Toolbox 

 

 

 

 

 

Gambar 3.50 Mengaktifkan toolbar Control Toolbox 

2. Toolbar dalam keadaan aktif apabila terdapat centang (�) dalam menu 

control Toolbox, tampilan toolbar control toolbox terlihat pada gambar  

 

 

 

 

Gambar 3.51 Toolbar Control Toolbox 

 

Design Mode 

 Untuk memilih objek kontrol pada control 
Toolbox,menempatkan kontrol pada 
worksheet, merubah ukuran kontrol,dan 
memindahkan posisi kontrol 

Properties 
 Untuk menampilkan window properties yang 

digunakan, untuk mengatur properties 
kontrol yang sedang aktif 

View Code 

 Untuk menampilkan kode kontrol yang 
sedang aktif melalui window code 
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CheckBox 

 Kontrol untuk menampilkan beberapa 
pilihan yang dapat dipilih lebih dari satu 
 
 

TexBox 

 Kontrol untuk membuat kotak isian pada 
worksheet.pengguna dapat memasukan nilai 
(dapat berupa angka ataupun teks) dalam 
kotak isian 

ComandButton 
 Kontrol untuk membuat tombol yang akan 

menjalankan suatu perintah apabila tombol 
tersebut ditekan 

OptionButton 
 Kontrol untuk menampilkan beberapa 

pilihan yang hanya dapat dilihat salah satu 
 

ListBox 
 Kontrol untuk menampilkan pilihan yang 

dikelompokan dalam sebuah daftar pilihan 
yang dapat digeser secara vertical 

ComboBox 

 Kontrol untuk menampilkan daftar pilihan 
yang dikelompokan dalam sebuah Texbox. 
pengguna juga dapat mengetik pilihannya 
dalam ComboBox,namun hal ini tergantung 
pada Style yang digunakan 

ToggleButton 
 Kontrol untuk membuat pilihan tombol                

on atau of 
 

SpinButton 
 Kontrol untuk menunjukan nilai yang 

berurutan dengan range yang konsisten 
 

ScrollBar 

 Kontrol untuk melakukan pemasukan data 
secara analog,yaitu dengan melakukan 
penggeseran pada bidang ScollBar ataupun 
penekanan pada tombol (atas,bawah,atau 
kanan) 

Label 

 Kontrol untuk membuat teks berupa 
informasi singkat kepada pengguna.Teks 
yang ditampilkan tidak dapat diubah 
pengguna 

Image 
 Kontrol untuk menampilkan gambar dalam 

formatbitmaps (*.bmp,*.dib), GIF(*gif), 
JPEG (*jpeg) 

More Control 

 Kontrol untuk menambah objek kontrol lain 
yang tidak ditampilkan dalam toolbar 
Control Toolbox 
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3. Pilih kontrol Button pada Control Toolbox dan klik mouse pada bidang 

worksheet langkah ini dilakukan untuk menambah kontrol (OptionButton) 

pada worksheet 

 

 

 

 

 

 

Gambar 3.52 Menambahkan Kontrol OptionButton 

4. Klik kanan kontrol OptionButton kemudian pilih menu Properties 

Muncul window Properties seperti Gambar 3.53 

 

 

 

 

 

 

Gambar 3.53 Window properties 

5. Ubah properti OptionButton menjadai Name = optInput; BackColor = & 

H000C0C0C0%, caption = Input;height = 19,5 left =9,75 Top =79,5 Value 

= True Width = 39,75. 
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6. Dengan cara yang sama tambahkan kontrol lainya pada form sheet 

sehingga tampilan Form Sheet menjadi seperti pada Gambar 3.54 

 

 

 

 

 

 

        Gambar 3.54 Tampilan Akhir Form Sheet Penerimaan 

 

  

 

   

 

 

 

       Gambar 3.55 Tampilan Akhir Form Sheet Pengeluaran 
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7.  Pengaturan setting properti pada objek kontrol selengkapnya sebagai berikut : 

Objek Setting Properti 

OptionButton 

Name = optInput; BackColor = & H000C0C0C0%, 

caption = Input;height = 19,5 left =9,75 Top =77,25 

Value = True Width = 39,75. 

OptionButton 

Name = optEdit; BackColor = & H000C0C0C0%, 

caption = Edit;height = 19,5 left =50,25 Top =79,5 

Value = False Width = 34,75. 

OptionButton 

Name = optCetak; BackColor = & H000C0C0C0%, 

caption = Nota;height = 19,5 left =492,75 Top =79,5 

Value = False Width = 65,25. 

ComandButton 
Name = CmdInput; caption = Input;height = 21 left 

=110,25 Top =111,75 Width = 43,5. 

ComandButton 
Name = CmdEdit; caption = Edit;height = 21 left 

=15,75 Top =111,75 Width = 43,5. 

ComandButton 
Name = CmdReset; caption = Reset;height = 21 left 

=62,25 Top =111,75 Width = 43,5. 

ComandButton 
Name = CmdHapusnota; caption = Hapusnota;height = 

21 left =267 Top =111,75 Width = 64,5. 

ComandButton 
Name = CmBuatNota; caption = Buat Nota;height = 

21 left =333.25 Top =111,75 Width = 64,5. 

ComandButton 
Name = CmdCetakNota; caption = Cetak;height = 21 

left =492 Top =180 Width = 64,5. 

CheckBox 

Name = chkDatabase; BackColor = & H000C0C0C0%, 

caption = Database;height = 19,5 left = 417 Top =181,5 

Value = True False Width = 58,5 

ListBox 

Name = ListNota; BoundColomn = 6, ColomnCount= 

6;height = 111 left = 15 Top =138 Width = 384 
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3.9  Kode Macro Form Sheet 

 

 

 

 

 

 

Gambar 3.56  Memilih Object Sheet1(form) 

1. Pilih menu Tools > Macro > Visual Basic Editor (atau tekan 

Alt+F11)untuk membuka Visual Basic Editor 

2. Pilih object Sheet1(Form) pada Microsoft Excel Object dalam proyek 

VBAProject 

3. Pilih menu View > Code atau tekan F7 kemudian ketik kode sebagai 

berikut   

'Kode saat Form Sheet aktif 
Private Sub Worksheet_Activate() 
 
'Seleksi sel A1 
Range("A1").Select 
Range("C5").Select 
'Ukuran window = 100% 
ActiveWindow.Zoom = 100 
 
End Sub 
 
'Kode saat tombol Buat Nota ditekan 
Private Sub cmdBuatNota_Click() 
 
'Kosongkan daftar nota 
listNota.Clear 
'Menambah no faktur 
Range("I5").Value = Range("I5").Value + 1 
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'Memberi nilai kotak periksa Database 
chkDatabase.Value = True 
'Memberi nilai pilihan Input 
optInput.Value = True 
'Kosongkan keterangan dan isi nota 
Sheets("Nota").Range("KeteranganNota").ClearContents 
Sheets("Nota").Range("IsiNota").ClearContents 
 
'Judul kolom daftar nota 
With listNota 
     .AddItem 
     .List(.ListCount - 1, 0) = "No" 
     .List(.ListCount - 1, 1) = "Nama Barang" 
     .List(.ListCount - 1, 2) = "Harga" 
     .List(.ListCount - 1, 3) = "Jumlah" 
     .List(.ListCount - 1, 4) = "Satuan" 
     .List(.ListCount - 1, 5) = "Total" 
     .ColumnWidths = 25 & ";" & 130 & ";" & _ 
     60 & ";" & 40 & ";" & 60 & ";" & 65 
End With 
 
End Sub 
 
'Kode saat tombol Hapus Nota ditekan 
Private Sub cmdHapusNota_Click() 
 
'wsNota = worksheet Nota 
Set wsNota = Sheets("Nota") 
 
listNota.Clear 
wsNota.Range("KeteranganNota").ClearContents 
wsNota.Range("IsiNota").ClearContents 
 
With listNota 
     .AddItem 
     .List(.ListCount - 1, 0) = "No" 
     .List(.ListCount - 1, 1) = "Nama Barang" 
     .List(.ListCount - 1, 2) = "Harga " 
     .List(.ListCount - 1, 3) = "Jumlah" 
     .List(.ListCount - 1, 4) = "Satuan" 
     .List(.ListCount - 1, 5) = "Total" 
     .ColumnWidths = 25 & ";" & 130 & ";" & _ 
     60 & ";" & 40 & ";" & 60 & ";" & 65 
End With 
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Range("C5").Select 
 
End Sub 
 
'Kode saat tombol Input ditekan 
Private Sub cmdInput_Click() 
 
Set wsDatabase = Sheets("Database") 
Set wsNota = Sheets("Nota") 
'Mendeklarasikan variabel BarisDatabase 
Dim BarisDatabase As Long 
Dim BarisNota As Long 
 
'Jika opsi Input tidak dalam keadaan terpilih 
If optInput.Value = False Then 
     MsgBox "Pilih opsi Input terlebih dulu", _ 
     vbOKOnly + vbExclamation, "Pilih Opsi Input" 
     optInput.Value = True 
     'Keluar dari prosedur 
     Exit Sub 
End If 
 
'Jika sel C5 dan C6 masih kosong 
If Range("C5").Value = "" And _ 
Range("C6").Value = "" Then 
     MsgBox "Kode dan Jumlah Barang belum diisi", _ 
     vbOKOnly + vbInformation, "Kode dan Jumlah Barang Kosong" 
     Range("C5").Select 
     Exit Sub 
'Jika sel C5 masih kosong 
ElseIf Range("C5").Value = "" Then 
     MsgBox "Kode Barang belum diisi", _ 
     vbOKOnly + vbInformation, "Kode Barang Kosong" 
     Range("C5").Select 
     Exit Sub 
'Jika sel C6 masih kosong 
ElseIf Range("C6").Value = "" Then 
     MsgBox "Jumlah Barang belum diisi", _ 
     vbOKOnly + vbInformation, "Jumlah Barang Kosong" 
     Range("C6").Select 
     Exit Sub 
End If 
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'Jika nota belum dibuat (masih kosong) 
If listNota.ListCount < 1 Then 
     MsgBox "Buat nota terlebih dulu", _ 
     vbOKOnly + vbInformation, "Buat Nota" 
     Exit Sub 
End If 
 
'Jika item yang diinput melebihi nota Penerimaan 
If listNota.ListCount > 26 Then 
     MsgBox "Jumlah item barang sudah maksimal", _ 
     vbOKOnly + vbInformation, "Nota Penerimaan Penuh" 
    Exit Sub 
End If 
 
'Pengisian daftar nota 
With listNota 
     .AddItem 
     'Pengisian kolom No Nota 
     .List(.ListCount - 1, 0) = listNota.ListCount - 1 
     'Pengisian kolom Nama Barang = sel F5 
     .List(.ListCount - 1, 1) = Range("F5").Value 
     'Pengisian kolom harga = sel F6 
     .List(.ListCount - 1, 2) = Range("F6").Value 
     'Pengisian kolom Jumlah = sel C6 
     .List(.ListCount - 1, 3) = Range("C6").Value 
     'Pengisian kolom  satuan  = sel F7 
     .List(.ListCount - 1, 4) = Range("F7").Value 
     'Pengisian kolom Total = sel F8 
     .List(.ListCount - 1, 5) = Range("F8").Value 
End With 
 
'Pengisian nota Penerimaan (worksheet nota) 
With wsNota 
     'Pengisian setelah baris terakhir pada kolom B 
     BarisNota = .Cells(.Rows.Count, "B"). _ 
     End(xlUp).Offset(1, 0).Row 
     'Pengisian kolom Nama Barang 
     .Cells(BarisNota, 2).Value = Range("F5").Value 
     'Pengisian kolom harga 
     .Cells(BarisNota, 3).Value = Range("F6").Value 
     'Pengisian kolom Jumlah 
     .Cells(BarisNota, 4).Value = Range("C6").Value 
     'Pengisian kolom satuan 
     .Cells(BarisNota, 5).Value = Range("F7").Value 
     'Pengisian kolom Total 
     .Cells(BarisNota, 6).Value = Range("F8").Value 
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End With 
 
'Menghapus range C5:C6 
Range("C5:C6").ClearContents 
Range("C5").Select 
 
End Sub 
 
'Kode saat tombol Edit ditekan 
Private Sub cmdEdit_Click() 
 
Set wsNota = Sheets("Nota") 
 
'Nomor nota = isi sel C7 
NomorNota = Range("C7").Value 
 
 
'Jika opsi Edit tidak dalam keadaan terpilih 
If optEdit.Value = False Then 
     MsgBox "Pilih opsi Edit terlebih dulu", _ 
     vbOKOnly + vbExclamation, "Pilih Opsi Edit" 
     optEdit.Value = True 
     Exit Sub 
End If 
 
'Jika nomor nota yang akan diedit > jumlah no nota 
If NomorNota >= listNota.ListCount Then 
     MsgBox "Cek isian nomor nota", _ 
     vbOKOnly + vbExclamation, "Error No Nota" 
     Exit Sub 
'Jika nomor nota <= 0 atau no nota kosong 
ElseIf NomorNota <= 0 Or NomorNota = "" Then 
     MsgBox "Cek isian nomor nota", _ 
     vbOKOnly + vbExclamation, "Error No Nota" 
     Exit Sub 
End If 
 
'Perubahan pada daftar nota 
With listNota 
     .List(NomorNota, 1) = Range("F5").Value 
     .List(NomorNota, 2) = Range("F6").Value 
     .List(NomorNota, 3) = Range("C6").Value 
     .List(NomorNota, 4) = Range("F7").Value 
     .List(NomorNota, 5) = Range("F8").Value 
End With 
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'Perubahan pada nota penerimaan 
With wsNota 
     .Cells(12 + NomorNota, 2) = Range("F5").Value 
     .Cells(12 + NomorNota, 3) = Range("F6").Value 
     .Cells(12 + NomorNota, 4) = Range("C6").Value 
     .Cells(12 + NomorNota, 5) = Range("F7").Value 
     .Cells(12 + NomorNota, 6) = Range("F8").Value 
End With 
 
optInput.Value = True 
Range("C5:C7").ClearContents 
Range("C5").Select 
 
End Sub 
 
'Kode saat tombol Reset ditekan 
Private Sub cmdReset_Click() 
 
Range("C5:C7").ClearContents 
Range("C5").Select 
 
End Sub 
 
'Kode saat tombol Cetak Nota ditekan 
Private Sub cmdCetakNota_Click() 
 
Set wsDatabase = Sheets("Database") 
Set wsNota = Sheets("Nota") 
Dim BarisDatabase As Long 
 
'Jika opsi Cetak tidak dalam keadaan terpilih 
If optCetak.Value = False Then 
     MsgBox "Pilih opsi Cetak terlebih dulu", _ 
     vbOKOnly + vbExclamation, "Pilih Opsi Cetak" 
     optCetak.Value = True 
     Exit Sub 
End If 
 
If Range("H9").Value = "" And _ 
Range("H11").Value = "" Then 
     MsgBox "Nama  belum diisi", _ 
     vbOKOnly + vbInformation, "Nama  Kosong" 
     Range("H9").Select 
     Exit Sub 
ElseIf Range("H9").Value = "" Then 
     MsgBox "Nama belum diisi", _ 
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     vbOKOnly + vbInformation, "Nama Kosong" 
     Range("H9").Select 
     Exit Sub 
 
End If 
 
'Jika tombol Cancel ditekan 
If pesanCetak = vbCancel Then 
    Exit Sub 
End If 
 
JumlahBarang = listNota.ListCount - 1 
 
'Jika opsi Database dalam keadaan terpilih 
If Sheets("Form").chkDatabase.Value = True Then 
 
     
     'Memasukkan data dalam daftar nota (listNota) _ 
     ke worksheet database 
     With wsDatabase 
 
     BarisDatabase = .Cells(.Rows.Count, "A"). _ 
     End(xlUp).Offset(0, 0).Row 
 
     For i = 1 To JumlahBarang 
     With .Cells(BarisDatabase + i, "A") 
        .Value = Now 
        .NumberFormat = "dd/mm/yyyy" 
    End With 
    .Cells(BarisDatabase + i, 2).Value = Range("I5").Value 
    .Cells(BarisDatabase + i, 3).Value = Range("I6").Value 
    .Cells(BarisDatabase + i, 4).Value = listNota.List(i, 1) 
    .Cells(BarisDatabase + i, 5).Value = listNota.List(i, 2) 
    .Cells(BarisDatabase + i, 6).Value = listNota.List(i, 3) 
    .Cells(BarisDatabase + i, 7).Value = listNota.List(i, 4) 
    .Cells(BarisDatabase + i, 8).Value = listNota.List(i, 5) 
    Next i 
 
    End With 
 
End If 
'Refresh PivotTable 
Worksheets("PivotTable").PivotTables("PTTribina Primalestari"). _ 
PivotCache.Refresh 
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'Memasukkan keterangan nota penerimaan 
With wsNota 
    .Cells(5, 5).Value = Range("I5").Value 
    .Cells(6, 5).Value = Now 
    .Cells(7, 5).Value = Range("H9").Value 
    .Cells(42, 6).Value = Range("H11").Value 
    .Cells(54, 3).Value = Range("H9").Value 
    .Cells(54, 6).Value = Range("I6").Value 
End With 
 
'Mencetak nota 
wsNota.PrintOut Copies:=1, Collate:=True 
 
wsNota.Range("KeteranganNota").ClearContents 
wsNota.Range("IsiNota").ClearContents 
 
Sheets("Form").Select 
 
chkDatabase.Value = False 
optInput.Value = True 
listNota.Clear 
Range("H9:I9").ClearContents 
Range("H11:I11").ClearContents 
 
With listNota 
     .AddItem 
     .List(.ListCount - 1, 0) = "No Nota" 
     .List(.ListCount - 1, 1) = "Nama Barang" 
     .List(.ListCount - 1, 2) = "Harga Barang" 
     .List(.ListCount - 1, 3) = "Jumlah" 
     .List(.ListCount - 1, 4) = "Satuan" 
     .List(.ListCount - 1, 5) = "Total" 
     .ColumnWidths = 25 & ";" & 130 & ";" & _ 
     60 & ";" & 40 & ";" & 60 & ";" & 65 
End With 
 
End Sub 
 
'Kode saat opsi Input dipilih 
Private Sub optInput_Click() 
     'Range dibatasi pada range C5:C6 
     Sheets("Form").ScrollArea = "C5:C6" 
     Range("C5:C7").ClearContents 
     Range("H9:I9").ClearContents 
     Range("H11:I11").ClearContents 
     Range("C5").Select 
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End Sub 
 
'Kode saat opsi Edit dipilih 
Private Sub optEdit_Click() 
     Sheets("Form").ScrollArea = "C5:C7" 
     Range("C5:C7").ClearContents 
     Range("H9:I9").ClearContents 
     Range("H11:I11").ClearContents 
     Range("C5").Select 
End Sub 
 
'Kode saat opsi Cetak dipilih 
Private Sub optCetak_Click() 
    Sheets("Form").ScrollArea = "H9:I11" 
    Range("C5:C7").ClearContents 
    Range("H9:I9").ClearContents 
    Range("H11:I11").ClearContents 
    Range("H9").Select 
End Sub 
 

3.10  Membuat Rancangan  Form Login 

 Aplikasi penerimaan dan pengeluaran barang material yang dibuat perlu 

diproteksi agar tidak digunakan oleh sembarang orang. Untuk menjalankan 

aplikasi pengguna harus memasukan User ID dan Password yang sesuai. 

Pengguna yang dapat mengunakan aplikasi penerimaan dan Pengeluaran hanya 

orang  yang mempunyai otoritas sebagai Administrator ataupun petugas gudang, 

pengguna dengan otoritas administrator dapat menggunakan aplikasi penerimaan 

dan pengeluaran dengan hak akses penuh yaitu melakukan transaksi penerimaan 

dan pengeluaran mengelola database hingga melakukan modifikasi terhadap 

aplikasi yang dibuat.Sedangkan penguna dengan otoritas petugas gudang dapat 

menggunakan aplikasi sebatas hanya untuk melakukan transaksi penerimaan dan 

pengeluaran. 
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3.10.1  Form Login Petugas 

 Form login petugas digunakan sebagai penampung User ID dan password 

pengguan dengan otoritas petugas agar dapat melakukan transaksi melalui aplikasi 

penerimaan dan pengeluaran. Daftar User ID dan password petugas telah dibuat 

pada tabel bantu form login petugas  

A. Desain Form  

Langkah pengerjaan dalam mendesain form login petugas adalah : 

1. Pilih Menu Tools > Macro > Visual Basic editor (atau tekan Alt+F11) 

untuk membuka visual basic editor pada window visual basic editor pilih 

menu utama Insert > UserForm 

2. Tempatkan kontrol ke dalam Useform sehingga tampilan userform 

menjadi seperti pada gambar 3.57 

 

 

 

 

 

 

Gambar 3.57 Tampilan Form Login Petugas 
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3. Atur setting properti pada Userform dan objek kontrol sebagai berikut : 

Objek Setting Properti 

UserForm 
Nama = Form petugas;Caption = form Login 

petugas;height = 108;width = 174 

Label 
Nama = LbluserID;Caption = User ID ;height = 12; 

left = 6;Top = 12;width = 174 

Label 
Nama =Lblpassword;Caption = password;height = 

12; left = 6;Top = 36;width = 42 

TextBok 
Nama =txtuserID; height = 18; left = 48;Top = 

6;width = 114 

TextBox 
Nama =txtpassword; height = 18; left = 48;Top = 

30;width = 114;PasswordChar = * 

ComandButton 
Nama =cmdcancel;Caption = Cancel;height = 24; 

left = 60;Top = 54;width = 48 

ComandButton 
Nama =cmdOk;Caption = OK;height = 24; left = 

114;Top = 54;width = 48 

 

B. Kode Macro Login Petugas 

 Buka Project Explore kemudian pilih Objek Form Petugas pada daftar 

Objek Form pilih menu View > code atau tekan F7 kemudian ketik kode sebagai 

berikut : 
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'Kode menonaktifkan close button Form Login petugas 
Private Sub UserForm_QueryClose _ 
(Cancel As Integer, CloseMode As Integer) 
     
If CloseMode = vbFormControlMenu Then 
    Cancel = True 
End If 
 
End Sub 
 
'Kode saat tombol OK ditekan 
Private Sub cmdOK_Click() 
 
Set wsForm = Sheets("Form") 
 
'Jika kotak isian User ID masih kosong 
If txtUserID.Value = "" Then 
    MsgBox "Isi User ID terlebih dulu", _ 
    vbOKOnly + vbInformation, "User ID Kosong" 
    txtUserID.SetFocus 
    Exit Sub 
'Jika kotak isian Password masih kosong 
ElseIf txtPassword.Value = "" Then 
    MsgBox "Isi Password terlebih dulu", _ 
    vbOKOnly + vbInformation, "Password Kosong" 
    txtPassword.SetFocus 
    Exit Sub 
End If 
 
'Nilai sel AB3 pada worksheet Form (Form Sheet) 
wsForm.Range("AB3").Value = txtUserID.Value 
 
'Jika User ID atau Password petugas yang dimasukkan salah 
If wsForm.Range("AB4").Text <> txtPassword.Value Then 
    wsForm.Range("AB3").Value = wsForm.Range("I6").Value 
    wsForm.Range("AB3").Copy 
    wsForm.Range("AB3").PasteSpecial Paste:=xlPasteValues 
    LoginSalah = MsgBox("User ID atau Password salah" _ 
    & vbCrLf & "Login lagi?", _ 
    vbOKCancel + vbInformation, "Error Login") 
    If LoginSalah = vbOK Then 
        txtUserID.Value = "" 
        txtPassword.Value = "" 
        txtUserID.SetFocus 
    Else 
        Unload Me 
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        Call Auto_Close 
        ThisWorkbook.Close 
    End If 
'Jika User ID atau Password petugas yang dimasukkan benar 
Else 
    wsForm.Range("I6").Value = txtUserID.Value 
    'Memanggil prosedur GoMenupetugas 
    Call GoMenupetugas 
    Call Proteksi 
    'Satus bar pemakai aplikasi adalah petugas 
    Application.StatusBar = "Login petugas" 
    Unload Me 
End If 
 
End Sub 
 
'Kode saat tombol Cancel ditekan 
Private Sub cmdCancel_Click() 
 
Unload Me 
Application.DisplayAlerts = False 
ThisWorkbook.Close 
Application.DisplayAlerts = True 
 
End Sub 
 
'Kode prosedur Proteksi 
Sub Proteksi() 
 
'Lanjutkan program apabila terjadi error 
On Error Resume Next 
 
'Mendeklarasikan WS sebagai worksheet 
Dim WS As Worksheet 
 
Set wsForm = Sheets("Form") 
Set wsNota = Sheets("Nota") 
 
'Menyembunyikan worksheet Database, _ 
PivotTable dan PivotChart 
Sheets(Array("Database", "PivotTable", _ 
"PivotChart")).Visible = False 
 
'Proteksi workbook 
ActiveWorkbook.Protect Password:= _ 
wsForm.Range("AE4").Value, _ 
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Structure:=True, Windows:=False 
'Proteksi Form Sheet 
If wsForm.ProtectContents = False Then 
    wsForm.Protect Password:=wsForm.Range("AE4").Value 
    wsForm.EnableSelection = xlUnlockedCells 
End If 
 
'Proteksi Nota Penerimaan 
If wsNota.ProtectContents = False Then 
    wsNota.Protect Password:=wsForm.Range("AE4").Value 
    wsNota.EnableSelection = xlUnlockedCells 
End If 
     
wsForm.Select 
wsForm.optInput.Value = True 
wsForm.ScrollArea = "C5:C6" 
 
End Sub 
 
'Kode prosedur GoMenupetugas (menu untuk petugas) 
Sub GoMenupetugas() 
 
Dim MenuUtama As CommandBarControl 
Set MenuUtama = Application. _ 
CommandBars("Worksheet Menu Bar").Controls("Sales App") 
 
'Menampilkan menu Login petugas 
MenuUtama.Controls("Login petugas").Visible = True 
MenuUtama.Controls("Login Administrator").Visible = True 
'Menyembunyikan menu View Database 
MenuUtama.Controls("View"). _ 
Controls("View Database").Visible = False 
MenuUtama.Controls("View"). _ 
Controls("View PivotTable").Visible = False 
MenuUtama.Controls("View"). _ 
Controls("View PivotChart").Visible = False 
MenuUtama.Controls("View"). _ 
Controls("View Nota").Visible = True 
MenuUtama.Controls("Form Sheet").Visible = True 
MenuUtama.Controls("Form Penerimaan").Visible = True 
MenuUtama.Controls("Form Database").Visible = False 
MenuUtama.Controls("Form Modifikasi").Visible = False 
MenuUtama.Controls("About").Visible = True 
 
End Sub 
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Form Login Administrator 

 Form login adminstrator digunakan sebagai penampung User ID dan 

password yang harus didisi pengguna dengan otoritas administrator agar dapat 

menggunakan aplikasi penerimaan dan pengeluaran dengan hak akses hingga 

meliputi melakukan perubahan desain dan pengelolaan penerimaan dan 

pengeluaran yang dibutuhkan. 

A. Desain From Login Administrator 

Langkah pengerjaan dalam mendesain form Login petugas adalah : 

Pilih Menu Tools > Macro > Visual Basic editor (atau tekan Alt+F11) untuk 

membuka visual basic editor pada window visual basic editor pilih menu utama 

Insert > UserForm.Tempatkan kontrol ke dalam Useform sehingga tampilan 

userform menjadi seperti pada gambar 3.58 

  

 

 

 

 

Gambar 3.58 tampilan Form Login Administrator 
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Atur setting properti pada Userform dan objek kontrol sebagai berikut : 

 

Objek Setting Properti 

UserForm 
Nama = Form Administrator;Caption = form Login 

Admnistrator;height = 108;width = 174 

Label 
Nama = LbluserID;Caption = User ID ;height = 12; left 

= 6;Top = 12;width = 42 

Label 
Nama =Lblpassword;Caption = password;height = 12; 

left = 6;Top = 36;width = 42 

TextBok 
Nama =txtuserID; height = 18; left = 48;Top = 6;width 

= 114 

TextBox 
Nama =txtpassword; height = 18; left = 48;Top = 

30;width = 114;PasswordChar = * 

ComandButton 
Nama =cmdcancel;Caption = Cancel;height = 24; left = 

60;Top = 54;width = 48 

ComandButton 
Nama =cmdOk;Caption = OK;height = 24; left = 

114;Top = 54;width = 48 

 

B. Kode Macro Login Administrator  

 Buka Project Explore kemudian pilih Objek FormPetugas pada daftar 

Objek Form pilih menu View > code atau tekan F7 kemudian ketik kode sebagai 

berikut : 

'Kode menonaktifkan close button Form Login Administrator 
Private Sub UserForm_QueryClose _ 
(Cancel As Integer, CloseMode As Integer) 
     
If CloseMode = vbFormControlMenu Then 
    Cancel = True 
End If 
 
End Sub 
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'Kode saat tombol OK ditekan 
Private Sub cmdOK_Click() 
 
Set wsForm = Sheets("Form") 
 
'Jika kotak isian User ID masih kosong 
If txtUserID.Value = "" Then 
    MsgBox "Isi User ID terlebih dulu", _ 
    vbOKOnly + vbInformation, "User ID Kosong" 
    txtUserID.SetFocus 
    Exit Sub 
ElseIf txtPassword.Value = "" Then 
    MsgBox "Isi Password terlebih dulu", _ 
    vbOKOnly + vbInformation, "Password Kosong" 
    txtPassword.SetFocus 
    Exit Sub 
End If 
 
'Jika User ID dan Password yang dimasukkan salah 
If txtUserID.Value <> wsForm.Range("AE3").Value And _ 
txtPassword.Value <> wsForm.Range("AE4").Value Then 
    LoginSalah = MsgBox("User ID dan Password salah" _ 
    & vbCrLf & "Login lagi?", _ 
    vbOKCancel + vbInformation, "Error Login") 
    If LoginSalah = vbOK Then 
        txtUserID.Value = "" 
        txtPassword.Value = "" 
        txtUserID.SetFocus 
    Else 
        Unload Me 
        Call Auto_Close 
        ThisWorkbook.Close 
    End If 
'Jika User ID yang dimasukkan salah 
ElseIf txtUserID.Value <> wsForm.Range("AE3").Value Then 
    LoginSalah = MsgBox("User ID salah" _ 
    & vbCrLf & "Login lagi?", _ 
    vbOKCancel + vbInformation, "Error Login") 
    If LoginSalah = vbOK Then 
        txtUserID.Value = "" 
        txtPassword.Value = "" 
        txtUserID.SetFocus 
    Else 
        Unload Me 
        ThisWorkbook.Close 
    End If 
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'Jika Password yang dimasukkan salah 
ElseIf txtPassword.Value <> wsForm.Range("AE4").Value Then 
    LoginSalah = MsgBox("Password salah" _ 
    & vbCrLf & "Login lagi?", _ 
    vbOKCancel + vbInformation, "Error Login") 
    If LoginSalah = vbOK Then 
        txtUserID.Value = "" 
        txtPassword.Value = "" 
        txtUserID.SetFocus 
    Else 
        Unload Me 
        ThisWorkbook.Close 
    End If 
'Jika User ID dan Password yang dimasukkan benar 
Else 
    'Memanggil prosedur GoMenuAdministrator 
    Call GoMenuAdministrator 
   'Memanggil prosedur BukaProteksi 
    Call BukaProteksi 
    'Refresh PivotTable 
    Sheets("PivotTable").PivotTables("PTTribina Primalestari"). _ 
    PivotCache.Refresh 
    Application.StatusBar = "Login Administrator" 
    Unload Me 
     
End If 
 
End Sub 
 
'Kode saat tombol Cancel ditekan 
Private Sub cmdCancel_Click() 
 
Unload Me 
Application.DisplayAlerts = False 
ThisWorkbook.Close 
Application.DisplayAlerts = True 
 
End Sub 
 
'Kode prosedur BukaProteksi 
Sub BukaProteksi() 
 
 
 
 
'Lanjutkan program apabila terjadi error 
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On Error Resume Next 
 
Set wsForm = Sheets("Form") 
Set wsNota = Sheets("Nota") 
Set wsDatabase = Sheets("Database") 
Set wsPivotTable = Sheets("PivotTable") 
Set wsPivotChart = Sheets("PivotChart") 
 
'Buka proteksi workbook 
ActiveWorkbook.Unprotect Password:=wsForm. _ 
Range("AE4").Value 
 
'Buka proteksi Form Sheet 
If wsForm.ProtectContents = True Then 
    wsForm.Unprotect Password:=wsForm.Range("AE4").Value 
End If 
 
'Buka proteksi Nota penerimaan 
If wsNota.ProtectContents = True Then 
    wsNota.Unprotect Password:=wsForm.Range("AE4").Value 
End If 
 
'Tampilkan worksheet database penerimaan 
wsDatabase.Visible = True 
wsPivotTable.Visible = True 
wsPivotChart.Visible = True 
wsForm.Select 
wsForm.ScrollArea = "" 
 
End Sub 
 
Sub GoMenuAdministrator() 
 
Dim MenuUtama As CommandBarControl 
 
Set MenuUtama = Application. _ 
CommandBars("Worksheet Menu Bar").Controls("Sales App") 
 
'Menampilkan seluruh menu aplikasi penerimaan 
MenuUtama.Controls("Login petugas").Visible = True 
MenuUtama.Controls("Login Administrator").Visible = True 
MenuUtama.Controls("View"). _ 
Controls("View Database").Visible = True 
MenuUtama.Controls("View"). _ 
Controls("View PivotTable").Visible = True 
MenuUtama.Controls("View"). _ 
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Controls("View PivotChart").Visible = True 
MenuUtama.Controls("View"). _ 
Controls("View Nota").Visible = True 
MenuUtama.Controls("Form Sheet").Visible = True 
MenuUtama.Controls("Form penerimaan").Visible = True 
MenuUtama.Controls("Form Database").Visible = True 
MenuUtama.Controls("Form Modifikasi").Visible = True 
MenuUtama.Controls("About").Visible = True 
 
End Sub 
 
 
 
 
 
 


